集成开发环境 u’nSP IDE介绍 开发工具--- u’nSP IDE μ’nSP™ 集成开发环境,它集程序的编辑、编 译、链接、调试以及仿真等功能为一体。具有友 好的交互界面、下拉菜单、快捷键和快速访问命 令列表等,使人们的编程、调试工作更加方便且 高效。 4 窗口 1、Workspace Window 2、Edit Window 3、Output Window 4、Debug Window 变量表 Watch 窗口 寄存器 Register 窗口 内存 Memory 窗口 反汇编窗口 Disassemble 窗口 Workspace Window Edit Window Output Window μ’nSP.

download report

Transcript 集成开发环境 u’nSP IDE介绍 开发工具--- u’nSP IDE μ’nSP™ 集成开发环境,它集程序的编辑、编 译、链接、调试以及仿真等功能为一体。具有友 好的交互界面、下拉菜单、快捷键和快速访问命 令列表等,使人们的编程、调试工作更加方便且 高效。 4 窗口 1、Workspace Window 2、Edit Window 3、Output Window 4、Debug Window 变量表 Watch 窗口 寄存器 Register 窗口 内存 Memory 窗口 反汇编窗口 Disassemble 窗口 Workspace Window Edit Window Output Window μ’nSP.

集成开发环境
u’nSP IDE介绍
2
开发工具--- u’nSP IDE
μ’nSP™ 集成开发环境,它集程序的编辑、编
译、链接、调试以及仿真等功能为一体。具有友
好的交互界面、下拉菜单、快捷键和快速访问命
令列表等,使人们的编程、调试工作更加方便且
高效。
3
4
窗口
1、Workspace Window
2、Edit Window
3、Output Window
4、Debug Window
变量表 Watch 窗口
寄存器 Register 窗口
内存 Memory 窗口
反汇编窗口 Disassemble 窗口
5
Workspace Window
6
Edit Window
7
Output Window
8
μ’nSP IDE使用流程
 打开μ’nSP IDE工具软件
方法:选择[开始]→[程序]→[sunplus]→
[unSP IDE 1.18.1]
 建立一个新项目
选择主菜单[file]->[new]->[project]->[file]
->键入文件名;并在[location]下选择存放路径
 在该项目的源文件夹(source files)下建立一个汇
编语言文件或C语言文件
选择主菜单[File]->[new]->[file](选择asm或
C文件)->[ file]->[文件名]
9
10
 在相应的 .asm文件或 .c文件内编程
 选择硬件仿真方式
 编译程序:选择主菜单[build]->[build]
(快捷键为F7)
 下载程序:选择主菜单[build]->[StartDebug]->
[Download](快捷键为F8)
此时程序已被下载到单片机的程序存储器中,可脱
机运行
 运行程序:选择主菜单[build]->[start debug]
-> [Download]-> [Go](快捷键为F5)
11
编写程序
12
文件路径的指定
Tools → Option → Directories
头文件
13
库文件
μ’nSP IDE调试
 调试工具(Build Tool)的使用方法介绍
 调试窗口的使用方法介绍
 断点的设置和使用方法介绍
 单步执行和连续执行调试方法介绍
14
15
快捷键
调试工具
名称
16
17
调试窗口——查看寄存器
状态寄存器
状态寄存器值
刷新
使能中断
指令周期数复位
指令周期数
18
调试窗口——查看变量
19
调试窗口——查看存储器的值
20
调试窗口——反汇编窗口
21
断点的设置
【功能】F9是设置断点的快捷键,我们在调
试程序时有时候我们需要根据自己的实际情
况设置断点。
【操作】将鼠标放在需要程序停止的地方,
然后按功能键F9即可,再点击全速运行,PC
指针则会停在刚刚设置的断点处。
22
断点调试
设置/取消断点
取消所有断点
打开断点窗口
23
 单步执行
【功能】当我们在进行程序调试的时候,需要
单步跟踪,IDE提供三种单步执行方式:
Step Into:单步运行,进入子程序
Step Over:单步运行,不进入子程序
Step Out :单步进入子程序时,跳出子程序
24
 单步执行
【操作】在进行程序调试的时候,当设置了断点
后,程序将会停在断点处,这时,如果需要单步
继续往下执行,选择Step Into,或选择Build
Tool工具条中的钮(快捷方式F11),则会单步
跟踪,如运行至一子程序,则会进入子程序运行;
选择Step Over,或单击钮(快捷方式F10),则会
单步跟踪,不进入子程序;程序在进入子程序后,
如果选择Step Out或单击钮,则会跳出该子程序。
25
 连续执行
【功能】连续运行分两种:一种是全速运行(Go),
如下图所示,另一种则是在调试的模式下,程序
全速运行到光标处停止。
【操作】如果程序编译通过,需要软件或硬件仿真
时可选择[Build]->[Start Debug]->[Go],或快
捷键F5,也可以单击钮,即可出现全速运行的界
面;如果在调试过程中,需要使程序全速运行至
某一处停止,可以将鼠标放在该命令的某一条指
令前,然后单击[Debug]->[Run to Curson]即可。
26
 凌阳单片机网站:
http://www.sunplusMCU.com
 凌阳单片机咨询邮箱:
E_mail: [email protected]
 凌阳单片机咨询电话:
Tel: 010-62981668-2930
凌阳单片机推广中心竭诚为您服务
27