Transcript Document
Extra Materials Introduction to ArcWorkstation What’s it look like? Traditionally a UNIX based “command line interface” package… Ran on UNIX machines. You typed in commands, and it showed you the results in another simple window. What’s ArcWorkstation made up of? Made up of separate modules that communicate with each other. The command line interface is… Arc: core application for doing analysis, and using “workspaces” where all the files are kept for each project. ArcEdit: for editing maps interactively. ArcPlot: for neat plotting of maps. ArcTools: Pre-made AML scripts Grid: for working with image files/raster data. (Might also see on older systems: ArcTIN: 3D work; ArcPress: printing; ArcStorm: multiuser databases; ArcNetwork: networks). What is ArcWorkstation? You can think of it as two main bits… ARC – the starting program where most stuff is done. INFO – a database, which holds tables of related information, all tagged with a geographical location. Lets you analyse the database data using a map interface, and display the results as a map. Shape Data Point Me Polygon House Line Fence Polygon Pub Why bother with it? Because: ArcGIS 8/9.x doesn’t have the functionality of ArcWorkstation, and plenty of places still use it. There is still a lot of use of legacy AML code. There is still a lot of data floating around in Coverages. We’ll teach you enough to understand how it works and give you a foundation to work from if you come across it. The ArcInfo Data Model Store all the same types of features in one file using x,y coordinates… i.e. all the point features in one file, all the line features in another file, and all the associated nonlocation data in yet another file. Makes storage and handling easier. Makes analysis easier. The filenames show what kind of data they hold. e.g. Label Points are stored in a LAB (lab.adf) file. Storing Data Storing Vector data The files hold coordinate data and Feature Numbers that are assigned sequentially to Features in the file. Feature Number Coordinates #1 0,0 10,10 #2 10,10 10,0 #3 0,0 10,0 Tics Tics – geographical control points used to register (overlap) different datasets, and transform (eg. put in a new projection scheme) the data. For example, you might mark in known locations on two datasets, usually at the data edges, as Tics. Stored in a TIC file (tic.adf). Arcs Arcs - stored in an ARC file (arc.adf). A point where an Arc changes direction is called a “Vertex”. The start and ends of Arcs, and the crossing point between two Arcs, are called “Nodes”. The ARC file stores each Vertex and Node as an x,y coordinate. Data can be assigned to Nodes Polygons An area - can also have “islands” inside, that cut out inner areas. +42 Made from one (or more) Arcs. The end Node is the same as the starting one. Each also has a Label Point (x,y) associated with it, stored in a LAB file. Polygon-Arc List The Polygon-Arc List file (pal.adf) stores which Arcs make up each Polygon. That way we don’t need to store the Arc coordinates again. ARC PAL Feature Number Arcs 23 #1,#2,#3 #1 #2 +23 #3 Feature Number X,Y #1 0,0 10,10 #2 10,10 10,0 #3 0,0 10,0 Polygon-Arc List The outside or “Universe” Polygon is always feature number 1, ie. first in the PAL file. Islands start with a zero, followed by the Arcs. Topology Analysis we might want to do… “How do I move from Arc to Arc to get from A to B fastest?” “If I leave Polygon A going north, which Polygon do I enter?” To do these analyses we need some notion of Topology, ie. the spatial relationships between features. Topology in ArcInfo Three ways topology is defined in ArcInfo… Arcs connect at Nodes. Arcs have direction, and therefore a left and right side. Arcs that connect to surround an area make a Polygon. How Topology is stored Stored in the files. Note that polygons are listed clockwise in the PAL, with minus figures for reverse direction Arcs. N2 N1 PAL +23 N3 Feature Number Arcs 1 Outside Arcs 23 #1,#2,-#3 ARC/ATT Feature Number X,Y From Node To Node Left Polygon Right Polygon #1 0,0 10,10 N1 N2 1 23 #2 10,10 10,0 N2 N3 1 23 #3 10,0 0,0 N1 N3 23 1 Feature Attributes Info stores information about each feature in a Feature Attribute Table using the Feature Number to match the attribute data to the coordinates in the other files in a one-to-one relationship. Each data type has its own table type. Each feature will also have a unique User Defined ID kept in its table in addition to its Feature Number. PAL FAT Arc Feature Numbers Polygon Feature Number Polygon Feature Number User Defined ID Type Use #1,#2,#3 23 23 44 Park Public #111,#154,#16 24 24 56 Garden Domestic #22,#34,#17 42 42 47 Pond Public Types of Feature Attribute Table Label Points / Polygons – Point/Polygon Attribute Table (PAT / pat.adf file). Includes AREA and PERIMETER columns with the values associated with any Polygons for which the Points are labels. Can be used to hold points or Polygon labels, but not both. Arcs – Arc Attribute Table (ATT / att.adf file). Includes FNODE#, TNODE#, LPOLY#, RPOLY#, LENGTH columns. When Nodes have data associated with them Node Attribute Table (NAT / nat.adf file). Includes an ARC# column referencing one of the Arcs. Feature Attribute Table Format After the columns listed above usually come the Feature Number (NAME#) and the User Defined ID (NAME-ID) columns. Following these, users can then create more columns to hold attribute data. Example PAT Note that the Universe Polygon is first, and the AREA given for it is the negative total of the rest. AREA PERIMETER SOILS# SOILS-ID -2021474.264 8606.065 1 0 1186954.500 6134.177 2 43 Water 92.042 3 1 Id3 7345.473 4 2 Sg 10962.990 492.525 5 3 Id3 14700.509 468.122 6 4 Id3 18515.934 589.712 7 5 Ns1 369.352 393753.469 SOIL-CODE Other Vector data Region – several related Polygons, nested or overlapping. Stored in a PAT.regionName (pat.adf file). Annotation – text drawn along an associated feature. Stored in a T(ext)AT (txt.adf file). Section – an Arc / portion of Arc representing a part of a pathway. Stored in a SEC table (sec.adf file). Route – a pathway made out of multiple Sections. Stored in a R(oute)AT (rat.adf file). Putting features together So, we’ve seen that individual features are stored in files with similar types (eg. all the line features in a file of Arcs). When these are combined, you get a data “Coverage”. A Coverage usually contains one type of geographical information or analysis result, eg. “Geology”, “Roads”, or “Quickest routes” Several Coverages may go together in a map, and you can turn different ones on and off to display different facets of a map. Coverages In the file system, these are represented as the directories your data files go in. They let you keep data files together and display them at the same time. Usually it is the name of the Coverage that goes to form the Feature Number and ID column names. Eg. The SOILS coverage before gave our example PAT a SOILS# Feature Number column and a SOILS-ID column. Addition Coverage information As well as our data files, a Coverage will have several other pieces of information associated with it. A Coverage Extent (BND / bnd.adf file) - this records the upper right and lower left corners of a rectangle containing all the feature data in the Coverage. It need not contain all the Tic and Annotation points. A Coordinate Definition file (PRJ / prj.adf ) - holds the Coverage’s map projection information A Tolerances file (TOL / tol.adf ) - holds a number of processing tolerances, eg. How close Tics in different files need to be before they count as matching. Putting Coverages together Finally Coverages can be kept together in project areas called “Workspaces”. Workspaces allow you to keep all the data and Coverages you generate for a project in one place, separate from any other work you may be doing. In the file system they’re represented as directories which include all the Coverage directories you’re working on in a project. One of the first things you do on starting any ArcWorkstation project is move to your present Workspace. The Vector Data Model Different views of the same data. File system ArcCatalog Workspace Coverages Vector data Raster data TIN data Summary Vector data includes Label Points, Arcs, Polygons and Tics. The coordinates for the features of each type are stored in separate files, one file for each type. Within the files, each individual feature has a Feature Number and a set of coordinates. The Feature Number is used to link features to attribute data stored in a Feature Attribute Table of a particular type. You can get at the combined data through their representation as Tables in ArcWorkstation. Summary Data stored in separate files / tables can be combined to form Coverages. Coverages usually contain information about a single landuse or analysis result. All the Coverages in a project can be kept together in a Workspace. Coverages and Workspaces are represented as directories in the file system. ArcCatalog It is vital that you never alter the file names or location outside of the ArcGIS applications. You can get at most of the information in the files and change/move/delete them in ArcGIS. The best way to do these operations is in ArcCatalog. We looked at some of the functions of ArcCatalog in the last practical. We’ll add a bit more detail now. Navigating ArcCatalog starts up displaying your harddrive, but you can add additional drives. You can add online databases if they hold appropriate data. Databases are a whole other course! Check ArcCatalog Help files for more details! Data viewing Can view Coverages in a number of ways. Metadata “Data about Data”. Where it’s from and what’s happened to it. Who made it and what’s its problems. What does it contain, and how. ArcCatalog lets you see and change metadata for… Describing the data and where it’s from. Describing the spatial data form and projection etc. Describing the attributes associated with the data. Double-click on a metadata element to open up the metadata form. The metadata is in the Coverage’s metadata.xml file. XML is a markup language like HTML. You can open it in Internet Explorer if you want to see what it looks like. Altering and copying Coverages You can use ArcCatalog as if it were Windows Explorer to rename, delete, copy or move Coverages and other data items, and make new folders. You use exactly the same keys/menus as you would in Explorer. Most menu options can be got at by rightclicking on a folder or file. The only difference is that ArcCatalog simultaneously goes through and updates all the files ArcGIS needs to keep track of what’s happened to the data. Making a Workspace Making a new Workspace is as easy as making a new folder. File > New > ArcInfo Workspace (or right-click > New > ArcInfo Workspace) Rename the Workspace appropriately. If you look in Explorer, you’ll see an Info directory has been made in the Workspace directory to store related information. Making a Coverage Making a Coverage is almost as easy, but requires slightly more thought. File > New > Coverage… This brings up a “Wizard” (set of instructional forms to fill in) to help you. Name the Coverage You can use an existing coverage to supply boundary, tic and projection information. Fix the projection If you don’t supply a template, you’ll need to say what projection scheme it’s in, or pick none. Generate initial topology If you know which feature type will be important, you can generate the appropriate feature table. Other ways of manipulating files and Workspaces Command line from Arc (the web version of this lecture has equivalent notes for ArcWorkstation). Using any of the ArcTools. ArcTools is a set of AML routines with menus for doing tricky Arc tasks. Summary Never alter the files or directories outside of ArcGIS. The easiest way to alter, delete or move ArcGIS data is with ArcCatalog. It acts like Explorer, but informs Arc what it’s doing. You can manipulate data and directories using Arc or ArcTools. Cleaning in ArcCatalog Right-click on the Coverage > Properties General > clean Fuzzy Tolerance Fuzzy Tolerance : the distance up to which points will be considered the same and snapped to the same point. This helps eliminate slithers. Should be small (~1/100,000 BDN rectangle size). If too small an automatic value is given (see ArcDocs). x1 X 200 X 200 uncleaned cleaned Dangles Dangle Length : any overshooting Arc longer than this won’t be removed as an error. Usually zero for Arc Coverages, 0.05 inches (0.127 cm) for Polygons. Note that Tolerances can be set in the Coverage properties before this time (sets the TOL Table / file). x1 X 200 X 200 uncleaned cleaned Building in ArcCatalog After cleaning, hit the build button to build the Topology. At this point you can decide what Topology to build. Just because you digitised as Polygons doesn’t mean you can’t make a set of Arcs or Nodes here for your Coverage. The Polygons will be split or Nodes extracted as appropriate. Building in ArcCatalog Once you have your new Features (Arcs from Polygons, for example) you can go back into ArcMap and edit / delete bits using the Editor Select tool. Editing - ArcEdit By and large, not much point in using it now. However, there are a few useful commands if you can seem to clean/build your topologies. nodeerrors Lists Arc undershoots, overshoots and open Polygons. labelerrors Lists where Polygons are associated with multiple labels. This should only be a problem if importing a Coverage previously produced in ArcWorkstation. Error marks Errors are marked at the Nodes where there’s a problem. Note that pseudo-Nodes (Arc crosses or Arcs join to themselves) show as diamonds. These are ok, except where they show a missing Arc i.e. two labels in one Polygon. Overshoot Overshoot Undershoot Open Polygon Missing Arc Exporting The same ArcToolbox conversion tools let you export Coverages as different formats. Also the Arc export command. Should always clean and build before exporting. Supported formats include… “Generate” (.gen) ASCII files. Interchange “e-naught-naught” (.e00) files – a popular way of transfering ArcGIS Coverages – esp. UNIX to NT and vice versa. Includes all the information necessary. Data manipulation Coverage Feature Attribute Tables Info stores information about each feature in a Feature Attribute Table using the Feature Number to match the attribute data to the coordinates in the geography files in a one-to-one relationship. Each data type has its own table type. PAL FAT Arc Feature Numbers Polygon Feature Number Polygon Feature Number User Defined ID Type Use #1,#2,#3 23 23 44 Park Public #111,#154,#16 24 24 56 Garden Domestic #22,#34,#17 42 42 47 Pond Public Types of Feature Attribute Table Label Points – Point/Polygon Attribute Table (PAT / pat.adf file). Includes AREA and PERIMETER columns with the values associated with any Polygons for which the Points are labels. Arcs – Arc Attribute Table (ATT / att.adf file). Includes FNODE#, TNODE#, LPOLY#, RPOLY#, LENGTH columns. Example PAT Note that this Table has an extra, nonstandard column in it “SOIL-CODE”. AREA PERIMETER SOILS# SOILS-ID -2021474.264 8606.065 1 0 1186954.500 6134.177 2 43 Water 92.042 3 1 Id3 7345.473 4 2 Sg 10962.990 492.525 5 3 Id3 14700.509 468.122 6 4 Id3 18515.934 589.712 7 5 Ns1 369.352 393753.469 SOIL-CODE Joins You can produce data tables that float free from the FATs. If these have one column data in them that is… Unique: i.e. is different for each record. Also present in a FAT. …you can JOIN the Tables, that is, copy all or some of the data out of the free-floating table and into the FAT. 1 X P 1 A C X 2 Y Q 2 A D Y 3 Z R Data 3 B D Z 1 A C 2 A D 3 B D FAT New FAT Tables in ArcMap Selection Editing Table Calculations in ArcWorkstation In INFO use the CALC command. Select Table / Records to act on. Issue CALC command. Results can only be numeric. Can use other columns, e.g… CALCULATE ANNUAL_WAGE = MONTHLY * 12 For non-numeric you need an AML or Java routine. Table Relates INFO is a relational database: one Table item can be linked to multiple items in other Tables. Types of Relate Relates in Coverages Relation Objects in Geodatabases Table Relates This is done without adding the data to the Table, therefore storage space lower than a Join. Also means a group of people can access one large geography file, but connect different data to it. Usual to link a Feature Attribute Table (FAT) to an external data table. E.g. link a country geography to Tables of population, domestic products, etc. Table Joins The relationship between items in a join must be one-to-one. If not, JOIN will take the first value it comes across. FAT External Table Resulting Join Table SITE# SITE # SITES -ID SITESID MONTH RAINFA LL SITESID MONTH RAINFA LL 1 22 22 JAN 220 1 22 JAN 220 2 31 22 FEB 310 2 31 JAN 510 3 14 22 MAR 140 4 51 31 JAN 510 Table Relates Relates can store one-to-many relationships and they can be used in analysis. E.g. Show all SITES where at least one month has > 300mm RAINFALL and show the MONTH. FAT External Table MONTH Result SITE # SITES -ID SITESID RAIN FALL SITE# SITESID MONTH 1 22 22 JAN 220 1 22 FEB 2 31 22 FEB 310 2 31 JAN 3 14 22 MAR 140 4 51 31 JAN 510 Again, there must be an identically named column in each, holding the data used to link the Tables. ArcWorkstation vs. ArcGIS Note: ArcWorkstation can do many-to-one, but not one-to-many. ArcDesktop can do both. SITE # SOILTYPE 1 A 2 SOILTYPE SAND CLAY A 30 30 B B 20 60 3 B C 40 20 4 A D 30 50 SITE # SITES -ID SITESID 1 22 22 JAN 220 2 31 22 FEB 310 3 14 22 MAR 140 4 51 31 JAN 510 MONTH RAINFA LL Many-to-one One-to-many Coverage Relate Arc commands relate add Interactively or in one go, add a relate. You can have up to 100 at a time before you have to redefine one. relate drop Remove a relate. relate save name Saves a current set of relates to a file. relate restore name Gets saved relates. relate list Lists current relates. Interfaces ArcToolbox, ArcTools, Arc Parts of a relate Relation name: arbitrary name <= 8 letters. Table Identifier: name of the Table – usually not a Feature Attribute Table (FAT). Database: usually INFO. Note that you don’t specify a table – the relate works on any table with the right column – usually a FAT. Info Item: the column in the INFO FATs. Relate column: column in the non-FAT table Relate Type: how the Tables are linked. Relate access: rw (read-write), ro (read only) or auto (same as the FAT). Types of relate This is determined by the sorting in the Tables. Linear : no sorting – slow unless the FAT and external table are sorted, in which case fast. Ordered : related non-FAT table must be sorted by the values in the Relate column. Link : relate by Feature ID. Shouldn’t be used, as the system can change IDs without warning, making the relate outdated. Table: same conditions as ordered – but if an absolute match is missing the record in the related table with the next highest value is taken. First: only option if you are not working with INFO. Interfaces ArcToolbox, ArcTools, Arc Parts of a relate Relation name: arbitrary name <= 8 letters. Table Identifier: name of the Table – usually not a Feature Attribute Table (FAT). Database: usually INFO. Note that you don’t specify a table – the relate works on any table with the right column – usually a FAT. Info Item: the column in the INFO FATs. Relate column: column in the non-FAT table Relate Type: how the Tables are linked. Relate access: rw (read-write), ro (read only) or auto (same as the FAT). Types of relate This is determined by the sorting in the Tables. Linear : no sorting – slow unless the FAT and external table are sorted, in which case fast. Ordered : related non-FAT table must be sorted by the values in the Relate column. Link : relate by Feature ID. Shouldn’t be used, as the system can change IDs without warning, making the relate outdated. Table: same conditions as ordered – but if an absolute match is missing the record in the related table with the next highest value is taken. First: only option if you are not working with INFO. Arc Commands All ArcToolbox tools have equivalent Arc commands. Consult the ArcDocs command list under the tool names. Most also have easy to use interfaces under ArcTool’s Command Tools. Analysis in ArcWorkstation Geodatabases don’t exist. Equivalent is a Network Coverage which is used in ArcPlot. The Netcover command creates a Network Coverage and opens the command interface for issuing other network commands. ArcWorkstation Network functionality Finding minimum-cost paths Allocating supply and demand Gravity modeling Location-allocation modeling Building a distance matrix Determining connectivity Assigning turn impedances Ordering features Classifying features Listing travel directions Programming ArcWorkstation Please see the extra materials on AML.