Transcript Module 4

Module 4
Working with Elements
4. Working with Elements
Training Manual
• All postprocessing is done at the node and element level, a
majority of it with nodal quantities.
• But there are several situations where you may need to work
directly with elements:
– Special types of surface loads, such as a pressure that is not
normal to the surface
– Postprocessing of beams and element-specific data
– Composite (layered) elements
– Link and combination elements such as spars, springs, and
convection links
INTRODUCTION TO ANSYS 6.0 - Part 2
• Most preprocessing — geometry creation, meshing, and even
loading — is usually done with the help of solid modeling
entities.
October 30, 2001
Inventory #001571
4-2
...Working with Elements
Training Manual
A. Element Coordinate System
B. Surface Effect Elements
C. Element Table
D. Workshop
INTRODUCTION TO ANSYS 6.0 - Part 2
• In this chapter, we will present the following element-specific
topics:
October 30, 2001
Inventory #001571
4-3
Working with Elements
A. Element Coordinate System
Training Manual
• Its purpose is to orient the following quantities:
– orthotropic material properties (EX, KXX, etc.)
– strains and stresses calculated during solution (EPX, SX, SY,
etc.)
• Just like MAT (material), TYPE (element type), and REAL (real
constant set), the element c.s. is a fourth element attribute
called ESYS.
INTRODUCTION TO ANSYS 6.0 - Part 2
• Every element in a model has an element coordinate system
associated with it.
October 30, 2001
Inventory #001571
4-4
Working with Elements
...Element Coordinate System
Training Manual
J
I
– Line elements are generally oriented with
element X from node I to node J.
X
L
– Shells usually default to:
• element X from node I to node J
Z
• element Y perpendicular to element X
in the plane of the element
I
K
Y
X
J
• element Z normal to X-Y by right-hand
rule
O
P
– Solids default to global Cartesian.
M
N
Y
Z
Yg
Zg
X
K
I
Xg
J
INTRODUCTION TO ANSYS 6.0 - Part 2
• The default ESYS orientation depends on
the element type. For example:
October 30, 2001
Inventory #001571
4-5
Working with Elements
...Element Coordinate System
Training Manual
– The material property direction of a solid element, representing
fiberglass for example, may not be parallel to global Cartesian.
– To orient tangential pressures applied on surface effect
elements.
X
Yg
Zg
Xg
INTRODUCTION TO ANSYS 6.0 - Part 2
• The default ESYS is sufficient for most cases, but there are a
few situations where you might need to change it. Example:
October 30, 2001
Inventory #001571
4-6
Working with Elements
...Element Coordinate System
Training Manual
• The procedure is as follows:
1. Define a local coordinate system with the appropriate
orientation.
• Location is generally arbitrary.
• Utility Menu > WorkPlane > Local Coordinate Systems > Create
Local CS
INTRODUCTION TO ANSYS 6.0 - Part 2
• To change the default ESYS, you need to align it with a
specified local coordinate system (CSYS 11 or greater).
October 30, 2001
Inventory #001571
4-7
Working with Elements
...Element Coordinate System
Training Manual
3. Modify the ESYS attribute of all selected elements to the local
system number defined in step 1.
• Preprocessor > -Modeling- Move/Modify > -Elements- Modify Attrib
• Or EMODIF command (e.g, emodif,all,esys,11)
4. Reactivate all elements and switch back to previous coordinate
system (CSYS).
INTRODUCTION TO ANSYS 6.0 - Part 2
2. Select the desired elements.
October 30, 2001
Inventory #001571
4-8
Working with Elements
...Element Coordinate System
Training Manual
• A related issue is the normal orientation of shell elements.
– Defines the top and bottom faces.
– Determined by the node order (I-J-K-L) in which the element is
defined, which in turn is determined by the underlying area.
• Sometimes you may need to "flip"
the normal direction of some
elements to match the rest of the
model.
– Element plot in Powergraphics
mode uses different colors for the
top and bottom faces.
INTRODUCTION TO ANSYS 6.0 - Part 2
Shell Element Normals
October 30, 2001
Inventory #001571
4-9
Working with Elements
...Element Coordinate System
Training Manual
– Reverse the underlying area
– Or reverse the elements themselves
• To reverse the underlying area:
– Preprocessor > -Modeling- Move/Modify > -Areas- Area Normals
– Then pick the area with the "correct" orientation. ANSYS will
scan all areas and reverse those that don't match the correct
one. The attached elements are also reversed (by default).
INTRODUCTION TO ANSYS 6.0 - Part 2
• Two ways to flip shell element normals:
October 30, 2001
Inventory #001571
4-10
Working with Elements
...Element Coordinate System
Training Manual
– Preprocessor > -Modeling- Move/Modify > -Elements- Shell Normals
– Or issue ENORM,P
– Then pick an element with the "correct" orientation
INTRODUCTION TO ANSYS 6.0 - Part 2
• To reverse the shell elements directly:
October 30, 2001
Inventory #001571
4-11
Working with Elements
...Element Coordinate System
Training Manual
– Enter PREP7 and resume pipe.db (shell mesh of an IGES model;
note that some shells are reversed)
– Move/Modify > Shell Normals (or issue ENORM,P)
• pick one of the purple elements
– Replot elements and note the correct orientation
INTRODUCTION TO ANSYS 6.0 - Part 2
• Demo:
October 30, 2001
Inventory #001571
4-12
Working with Elements
B. Surface Effect Elements
Training Manual
– tangential to the surface, such as a shear load?
– spatially varying over the surface, such as a bolt load?
– oriented at an angle to the surface, such as ice load on a
rooftop?
• Surface effect elements provide an effective way to do this.
INTRODUCTION TO ANSYS 6.0 - Part 2
• How would you apply a pressure load that is:
October 30, 2001
Inventory #001571
4-13
Working with Elements
...Surface Effect Elements
Characteristics:
– They overlay the surface of an underlying mesh like a “skin.”
– They act as a conduit for surface loads.
– Creating them is very easy:
• Select nodes on the surface of interest.
• Activate the appropriate element type
• Issue ESURF (or Preprocessor > Create > Elements > Surf Effect > ...).
• Select all nodes.
INTRODUCTION TO ANSYS 6.0 - Part 2
•
Training Manual
October 30, 2001
Inventory #001571
4-14
Working with Elements
...Surface Effect Elements
Training Manual
– SURF151 & 153 are line elements (thermal and structural) meant
for edges of 2-D models.
– SURF152 & 154 are area elements (thermal and structural) meant
for surfaces of 3-D models.
• We will discuss only SURF154 in this section, but you can
apply the same concepts to the other elements.
SURF154 as depicted in
the Elements Reference
manual
INTRODUCTION TO ANSYS 6.0 - Part 2
• Available for both 2-D and 3-D models:
October 30, 2001
Inventory #001571
4-15
Working with Elements
...Surface Effect Elements
Training Manual
• The face number is a field in the "Apply PRES on elems"
dialog (Solution > -Loads- Apply > Pressures > On Elements), as
shown below.
Or the LKEY field on the SFE command:
– SFE, ELEM, LKEY, PRES, , VAL1, VAL2, VAL3, VAL4
INTRODUCTION TO ANSYS 6.0 - Part 2
• SURF154 uses different element face numbers to accept
different types of loads.
October 30, 2001
Inventory #001571
4-16
Working with Elements
...Surface Effect Elements
Training Manual
Face 1:
– Normal pressure.
– Positive value acts into the element (along element -Z).
– Example: sfe,all,1,pres,,1000 (after selecting desired elements).
INTRODUCTION TO ANSYS 6.0 - Part 2
• Suppose you apply a pressure of magnitude 1000 on a set of
SURF154 elements. Its orientation depends on which
element face is used.
October 30, 2001
Inventory #001571
4-17
Working with Elements
...Surface Effect Elements
– Tangential pressures, along element X & Y respectively.
– Example:
sfe,eflat,3,pres,,1000
sfe,eslope,2,pres,,1000
(eflat and eslope are components made of elements)
INTRODUCTION TO ANSYS 6.0 - Part 2
Faces 2 & 3:
Training Manual
October 30, 2001
Inventory #001571
4-18
Working with Elements
...Surface Effect Elements
Training Manual
– Normal pressure, tapered. Magnitude = P1 + XgP2 + YgP3 + ZgP4
• P1-P4 are specified VAL1-VAL4 on SFE command.
• Xg,Yg, Zg are the global Cartesian locations of the element's
integration points.
• P2,P3,P4 are the slopes in global X,Y,Z respectively and default
to P1 if left blank.
– Positive value acts into the element (along element -Z).
P2
P1
Xg=0
Xg
INTRODUCTION TO ANSYS 6.0 - Part 2
Face 4:
October 30, 2001
Inventory #001571
4-19
Working with Elements
...Surface Effect Elements
Training Manual
– For example, to apply a tapered pressure of 200 to 1000 in the
global X direction, with X values ranging from -2 to +2:
• Slope P2 = (1000-200)/4 = 200; P3 = 0; P4 = 0
• P1 is the value at Xg=0, calculated as P1 = 2(200) + 200 = 600
• sfe,eflat,4,pres,,600,200,0,0
INTRODUCTION TO ANSYS 6.0 - Part 2
Face 4 (cont'd):
October 30, 2001
Inventory #001571
4-20
Working with Elements
...Surface Effect Elements
Training Manual
– Vector-oriented pressure of magnitude P1.
– Direction =
P2 Xg  P3 Yg  P4Zg
P22  P32  P42
– P2,P3,P4 now represent the direction cosines of the vector and
have no effect on the magnitude.
– Example: sfe,eflat,5,pres,,1000,-1,-1,0 defines a pressure at angle
of 45° in the X-Y plane.
INTRODUCTION TO ANSYS 6.0 - Part 2
Face 5
October 30, 2001
Inventory #001571
4-21
Working with Elements
...Surface Effect Elements
Training Manual
– The magnitude of vector-oriented pressure also depends on
KEYOPT(11).
– KEYOPT(11)=0 (default) and 1 applies pressure on the projected
area of surface elements.
• Useful for bolt loading (or pin loading).
• Example: sfe,ecurv,5,pres,,1000,0,-1,0 defines a bolt load on
the curved surface, as shown by a POST1 contour plot below.
INTRODUCTION TO ANSYS 6.0 - Part 2
Face 5 (cont'd):
October 30, 2001
Inventory #001571
4-22
Working with Elements
...Surface Effect Elements
Training Manual
• Useful for inclined surfaces (such as a roof top) or wind
loads.
• Example: sfe,eslope,5,pres,,1000,0,-1,0 defines uniform, full
pressure on all faces of an inclined surface, as shown below.
INTRODUCTION TO ANSYS 6.0 - Part 2
– KEYOPT(11)=2 applies pressure on the full area.
October 30, 2001
Inventory #001571
4-23
Working with Elements
...Surface Effect Elements
Training Manual
– Torque loading of solid elements
• Apply tangential pressure with the help of a modified element
coordinate system.
• Useful for shafts and bolts
– The thermal versions (SURF151 & 152) have many capabilities,
including:
• Heat and mass transfer to 1-D pipe element FLUID116
• Easy calculation of heat loss (or gain) across a surface
• Radiation
INTRODUCTION TO ANSYS 6.0 - Part 2
• Other applications of surface effect elements:
October 30, 2001
Inventory #001571
4-24
Working with Elements
...Surface Effect Elements
Training Manual
– Enter PREP7 and resume boltload.db
– Add SURF154 as element type 1 (show options)
– Select bottom area of hole and nodes attached to it
– Activate TYPE 1 and issue ESURF to create surface elements
– Select everything and plot elements
– Select TYPE 1 elements and apply pressure on face 5:
• value= 1000, val2= 0, val3= -1, val4= 0
– Select everything, save db, and solve
– Plot and/or animate SY stresses in POST1
– Stay in POST1 (for next demo)
INTRODUCTION TO ANSYS 6.0 - Part 2
• Demo:
October 30, 2001
Inventory #001571
4-25
Working with Elements
C. Element Table
Training Manual
– Performing arithmetic operations among results data
– Accessing results data that are not directly available (such as for
certain line elements)
• It works somewhat like a spreadsheet:
– Each row represents an element
– Each column consists of data for the elements
Element No.
1
2
3
…
Item 1
Item 2
Item 3
…
INTRODUCTION TO ANSYS 6.0 - Part 2
• The element table, available in POST1 (the general
postprocessor), serves two functions:
October 30, 2001
Inventory #001571
4-26
Working with Elements
...Element Table
Training Manual
– First select the desired elements
– Load results data into the table
– List or plot the data
– Perform desired arithmetic operations
• Element table functions are located in the GUI under General
Postproc > Element Table.
INTRODUCTION TO ANSYS 6.0 - Part 2
• A typical element table session consists of the following
steps:
October 30, 2001
Inventory #001571
4-27
Working with Elements
...Element Table
Training Manual
– In most cases, you only need to use the element table for a
subset of the elements in the model.
– Therefore, the first step is to select the desired elements:
• by attributes (MAT, TYPE, REAL, or ESYS)
• by their nodes
• by attached solid modeling entities
• by results
• etc.
INTRODUCTION TO ANSYS 6.0 - Part 2
• Select the desired elements
October 30, 2001
Inventory #001571
4-28
Working with Elements
...Element Table
Training Manual
– Identify the data item you want to load and assign a name (label)
to it. The label is used for listings, plots, and operations.
• Use the ETABLE command (e.g, etable,evolume,volu)
• Or Element Table > Define Table…
INTRODUCTION TO ANSYS 6.0 - Part 2
• Loading results data into the table
October 30, 2001
Inventory #001571
4-29
Working with Elements
...Element Table
Training Manual
• For example, the effective pressure on face 5 of a SURF154
element is stored as sequence number “SMISC 17.”
To load it into the element table: etable,p5,smisc,17
Refer to your Basic Analysis Procedures Guide (available online) for details of the “sequence number method.”
INTRODUCTION TO ANSYS 6.0 - Part 2
– Some types of data can only be identified by sequence numbers,
which are documented in the Elements Reference manual.
October 30, 2001
Inventory #001571
4-30
Working with Elements
...Element Table
– Element Table > List Elem Table… (or PRETAB command)
INTRODUCTION TO ANSYS 6.0 - Part 2
• Listing or plotting element table data
Training Manual
October 30, 2001
Inventory #001571
4-31
Working with Elements
...Element Table
INTRODUCTION TO ANSYS 6.0 - Part 2
– Element Table > Plot Elem Table… (or PLETAB,name)
Training Manual
October 30, 2001
Inventory #001571
4-32
Working with Elements
...Element Table
Training Manual
INTRODUCTION TO ANSYS 6.0 - Part 2
– The default is to not average the data at the nodes, i.e, there is
one color per element. To get a smooth contour plot, activate
the averaging key.
October 30, 2001
Inventory #001571
4-33
Working with Elements
...Element Table
Training Manual
For example, if you load nodal displacements UX, the average
UX of the element’s nodes is stored per element.
– Other ways to review element table data:
• You can map the data onto a path and obtain a path plot or
listing.
• You can load three scalar quantities (such as element Xpressure, Y-pressure, and Z-pressure) and combine them to
obtain a vector plot.
– See the PLVECT command for details.
INTRODUCTION TO ANSYS 6.0 - Part 2
– Note that there is only one value per element for each of the data
items: the average or effective value for that element.
October 30, 2001
Inventory #001571
4-34
Working with Elements
...Element Table
– Somewhat like a spreadsheet, you can do
arithmetic operations among the element
table columns.
– Many operations are available:
• Add two columns (SADD)
• Multiply (SMULT)
• Compare and store the maximum or
minimum of two columns (SMAX or SMIN)
• Sum each column (SSUM — useful for
calculating the total volume of the
selected set of elements
• Etc.
INTRODUCTION TO ANSYS 6.0 - Part 2
• Performing operations
Training Manual
October 30, 2001
Inventory #001571
4-35
Working with Elements
...Element Table
INTRODUCTION TO ANSYS 6.0 - Part 2
– Example:
Training Manual
October 30, 2001
Inventory #001571
4-36
Working with Elements
...Element Table
Training Manual
• Use the *VGET command (or Utility Menu > Parameters > Get
Array Data…)
• Then use one of the array operations: *VOPER, *VSCFUN,
etc.
• For example, statistical measures such as mean and
standard deviation cannot be calculated at the element table
level, but are available for array parameters.
INTRODUCTION TO ANSYS 6.0 - Part 2
– If a desired operation is not available, you can “upload” an
element table item to an array parameter and use array
operations.
October 30, 2001
Inventory #001571
4-37
Working with Elements
...Element Table
Training Manual
• If you read in results for a different load step or from a
different results file, the element table is not automatically
updated.
– Issue ETABLE,REFL (or click the
Update button in the Element
Table Data dialog) to “refill” or
update the table.
– The column header identifies
items as “current” or “previous”
depending on the status of the
data items.
INTRODUCTION TO ANSYS 6.0 - Part 2
Updating the Table
October 30, 2001
Inventory #001571
4-38
Working with Elements
...Element Table
Training Manual
– Read in load step 1, and store a result item in the element table
as A1 (for example).
– Then read in load step 2 and store the same result item as A2.
– Now you can compare A1 and A2 and store the maximum or
minimum in a third column, or do other desired operations.
– This scheme can be extended to compare different results files
for the same model.
INTRODUCTION TO ANSYS 6.0 - Part 2
• Since there is no automatic update of the element table, you
can easily compare the results between two load steps or two
different analyses, as follows:
October 30, 2001
Inventory #001571
4-39
Working with Elements
...Element Table
Training Manual
• To save the element table along with the ANSYS database:
– Save the database while still in POST1 (Toolbar > SAVE_DB or
SAVE command).
– Or use the "Save everything" option when exiting ANSYS
(Toolbar > QUIT or /EXIT,ALL command).
• To delete the entire element table:
– Element Table > Erase Table…
– Or ETABLE,ERASE
• To delete one item (column) in the element table:
– Use the Delete button in the Element Table Data dialog.
– Or ETABLE,name,ERASE
INTRODUCTION TO ANSYS 6.0 - Part 2
Saving and Deleting the Table:
October 30, 2001
Inventory #001571
4-40
Working with Elements
...Element Table
Demo:
–
Continue with previous "bolthole" demo
–
Select TYPE 1 elements (SURF154s) and all nodes attached to them
–
Bring up help for SURF154 and show the "Output Definitions" and "Item and
Sequence Numbers" tables. Note that P5EFF (effective pressure on face 5) is
SMISC 17.
–
Store SMISC,17 as P5 in the element table, plot it with and without averaging, then
list it
–
Select everything, return to PREP7, and set KEYOPT(11)=2 for SURF154 (Options >
K11 = full area w/tan). This changes face 5 pressures to "full" area instead of
projected area.
–
Switch to Solution, type in ANTYPE,,RESTART (to continue with load step 2), and
solve.
–
In POST1, read in load step 2, then select TYPE 1 elements (SURF154s) and all
nodes attached to them
–
Store SMISC,17 as P5A in the element table. (Notice that P5 from the previous load
step still exists.)
–
List the element table… P5A column should show all 1000s
–
Select everything and plot SY stresses, etc. Compare with load step 1 results.
INTRODUCTION TO ANSYS 6.0 - Part 2
•
Training Manual
October 30, 2001
Inventory #001571
4-41
Working with Elements
D. Workshop
Training Manual
W3. Bolt Torque
Please refer to your Workshop Supplement for instructions.
INTRODUCTION TO ANSYS 6.0 - Part 2
• This workshop consists of the following problem:
October 30, 2001
Inventory #001571
4-42