La mise en pratique sous SPSS des méthodes statistiques uni
Download
Report
Transcript La mise en pratique sous SPSS des méthodes statistiques uni
Centre Régional des Métiers de
L’Education et de la formation-Rabat
Exposé sous Titre :
La mise en pratique sous SPSS des méthodes
statistiques uni- et bidimensionnelle
Réalisé par :
LAMRANI El hassanya
plan
1 – Introduction
A - Définition de statistique
B - Définition de SPSS
2 - Statistique unidimensionnelle
A - Variables statistiques quantitatives
B - Variables qualitatives
3 - Statistique bidimensionnelle
A - Deux variables quantitatives
B - Une variable quantitative et une qualitative
C - Deux variables qualitatives
4 – Conclusion
1 - Introduction
A - Définition de statistique :
La statistique est la méthode de description des ensembles nombreux.
Elle est l’instrument de connaissance du phénomène collectif qui échappe en
raison de son étendue, de sa diversité et de son instabilité, à l’appréhension
directe et individuelle.
B. Définition de SPSS :
SPSS est un logiciel d’analyse et de traitement de données.
Ses fonctions diversifiées permettent de développer plusieurs types d’analyses :
- L’analyse « basique » (Fréquences, Moyennes, Tableaux croisés…)
- L’analyse économétrique (Régressions linéaires, multiples…)
- L’analyse de données (Analyse factorielle, …)
10, 11, 12, 13,
- Et bien d’autres encore…
14… 15 ???
2 - Statistique unidimensionnelle :
A - Variables statistiques quantitatives :
Lorsque cette variable est susceptible d’une mesure. elle est dite
quantitative ou mesurable.
Une variable statistique quantitative peut être discrète ou continue.
a. indices statistiques caractérisant une variable quantitative :
1 Paramètres de position : la moyenne, le mode, et la médiane.
2 paramètres de dispersion : Les paramètres de position ne sont pas
Suffisant pour caractériser une variable statistique :
Deux variable peuvent avoir les mêmes moyennes, mais ne se
répartissent pas de la même façon.
Les indices de dispersion complètent bien les paramètres de
position pour nous informer sur une variable.
La variance, L’écart-type, et L’étendue.
Variable quantitative discrète :
une variable statistique est dit discrète lorsque toutes les
valeurs possible sont des nombres isolée. C’est-à-dire si elles
prennent seulement des entières.
Exemple
On a noté les distances(en Milliers de km) parcourues par les 50 autocars
d’une Compagnie de transport; les données brutes sont ci-dessous :
15
12
18
21
25
24
31
36
15
45
12
14
25
26
32
33
41
15
42
38
40
11
15
24
28
32
25
28
41
44
32
10
17
25
36
44
45
48
48
32
13
18
14
24
25
13
44
48
49
11
Les étapes suivies pour saisir des données sous SPSS
► Lancez le logiciel.
► La boite de dialogue SPSS Statistics 17.0 s’affiche.
► Cliquez sur saisir des données puis sur ok.
► Les données peuvent être saisies dans l’éditeur de données, qui ressemble
un peu à une fenêtre d’Excel.
► Cliquez sur l’onglet Affichage des variables en bas de la fenêtre de l’éditeur
de données.
► Vous devez définir les variables qui seront utilisées. Dans cet exemple seul
une variable est nécessaire : Distances.
► Dans la cellule de première ligne de la première colonne saisissez le nom de
la variable : Distances.
► Un type de données numérique est automatiquement attribué au nouvelle
variable.
► Dans autre cas si vous voulez changer le type de la variable cliquez sur la
cellule de la ligne Distances de la colonne Type puis sur le bouton à droite de
la cellule Type pour ouvrir la boîte de dialogue Type de variable. Cette boîte de
dialogue contient les différents types disponibles (Numérique, Dollar,
chaîne…) puis sélectionnez un type.
Les étapes suivies pour saisir des données sous SPSS
Si vous ne saisissez pas de noms de variable, des noms uniques sont automatiquement créés.
► Cliquez sur l’onglet Affichage des données pour continuer à saisir des données.
► Le nom saisi dans l’affichage des variables est à présent l’en-tête de première colonne de l’affichage
des données.
► Commencer à saisir des données dans les lignes de la première colonne.
► Dans la colonne Distances, saisissez dans la première ligne 15, dans la deuxième ligne 12…
► La colonne Distances affiche actuellement un séparateur décimal alors que les valeurs sont des
entiers. Pour masquer le séparateur décimal de ces variables :
- Cliquez à nouveau sur l'onglet Affichage des variables en bas de la fenêtre de l'éditeur de données.
-Dans la colonne Décimales de la ligne Distances, saisissez 0 pour masquer la décimale, puis cliquez
sur l’onglet Affichage des données.
► Outre les données, vous pouvez aussi définir des étiquettes de variables pour les noms de variables.
Ces étiquettes sont utilisées dans les rapports statistiques et les diagrammes.
-Ces étiquettes deviennent très important puisqu’il indispensable d’écrire certains caractères ({,[…) ou
de faire des espaces dans la cellule Nom des variables.
- Ouvrez à nouveau la fenêtre Affichage de variable.
-Dans la cellule de la colonne Etiquette de la ligne Distances saisissez Distances (en milliers de km)
Les étapes suivies pour afficher les résultats sous SPSS :
Le menu Analyse contient une liste de modalités générales d'analyse de
rapport et d'analyse statistique.
►A partir des menus dans l’éditeur de données sélectionnez :
Analyse → statistiques descriptives → Effectifs.
La procédure effective sert à analyser et afficher les différents paramètres
statistiques et le nombre(N) et le pourcentage d’observations pour chaque
valeur observée d’une variable.
► Dans la boite de dialogue Effectifs Sélectionnez la variable valeurs et
déplacez-la dans la liste de variable(s) →cliquez sur statistiques.
► Sélectionnez Moyenne, Médiane,…., (options souhaités).
► Cliquez sur poursuivre.
► Désélectionnez sur Afficher les tableaux d’effectifs → cliquez sur ok
pour exécuter la procédure
Les résultats sous SPSS
Distances
(en millier de
km)
10
1
Pourcentage
2,0
Pourcentage
cumulé
2,0
11
2
4,0
6,0
12
2
4,0
10,0
13
2
4,0
14,0
14
2
4,0
18,0
15
4
8,0
26,0
17
1
2,0
28,0
18
2
4,0
32,0
21
1
2,0
34,0
24
3
6,0
40,0
25
5
10,0
50,0
26
1
2,0
52,0
28
2
4,0
56,0
Effectifs
La suite du tableaux
31
1
2,0
58,0
32
4
8,0
66,0
33
1
2,0
68,0
36
2
4,0
72,0
38
1
2,0
74,0
40
1
2,0
76,0
41
2
4,0
80,0
42
1
2,0
82,0
44
3
6,0
88,0
45
2
4,0
92,0
48
3
6,0
98,0
49
1
2,0
100,0
Total
50
100,0
Les paramètres statistiques
N
50
Moyenne
28,08
Médiane
25,50
Mode
25
Ecart-type
12,280
Variance
150,810
Minimum
10
Maximum
49
1. Pour illustrer la notion de base de la création de diagramme sous
SPSS de cet exemple vous suivez :
A partir des menus sélectionnez:
► Graphe → Générateur de diagrammes.
La boîte de dialogue Générateur de diagrammes est une fenêtre qui vous permet d'obtenir
l'aperçu d'un diagramme avant que vous ne le génériez.
► Cliquez sur l'onglet Galerie s'il n'est pas sélectionné puis sur bâtons. Les icônes
représentant les diagrammes en bâtons disponibles dans la galerie
apparaissent dans la boîte de dialogue.
►Faites glisser l'icône du diagramme en bâtons simples sur le « canevas », qui est en fait la
zone au-dessus de la galerie et au coté des variables . Le générateur de diagrammes
affiche un aperçu du diagramme sur le canevas. Notez que les données utilisées pour
dessiner le diagramme ne sont pas vos données en cours. Il s'agit d'exemples.
► Pour lui appliquer à votre exemple cliquez sur Propriété des éléments. La fenêtre
Propriété des éléments vous permet de modifier les propriétés des différents éléments
du diagramme. Ces éléments comprennent les éléments graphiques (comme les bâtons
du diagramme) et les axes du diagramme.
► Sélectionnez dans Modifier les propriétés de sur Batôns1:
Pour illustrer la notion de base de la création de
diagramme sous SPSS de cet exemple vous suivez :
-Puisque Bâton1 est sélectionné, les propriétés affichées s'appliquent aux éléments graphiques, en
particulier les éléments de bâtons.
-Sélectionnez dans Statistiques sur Effectif avec que La liste Statistiques affiche les statistiques
spécifiques qui sont disponibles (Histogramme, Effectifs cumulé, Moyenne…). Les mêmes
statistiques sont habituellement disponibles pour chaque type de diagramme.
- Sélectionnez dans Style des bâtons sur Moustache cette liste affiche aussi les différents types de
bâtons qui sont disponibles (Bâtons, barre en I, Moustache).
- Cliquez sur Appliquer.
► Désélectionnez dans Modifier les propriétés de sur X-Axe1(Bâtons) :
-Puisque X-Axe1(Bâtons) est sélectionnez vous pouvez modifier les éléments de l’axe X (Etiquette
de l’axe, la plage et le type de l’échelle).
La suite
-Ecrivez dans Etiquette de l’axe : Distances (en milliers de km) (c’est l’étiquette de
variable voyez la 4ème page).
-La page de l’échelle sert à contrôler l’apparition sur l’axe des x:
Dans Minimum, Maximum, Origine cliquez sur Automatique (les valeurs sur
l’axe x sont données par SPSS)
Dans Incrément principal (le pas de la subdivision de l’axe X) écrivez 2 (les
valeurs auront séparées d’un pas égale 2 Personnalisé)
-Cliquez sur Linéaire dans le type d’échelle puis sur Appliquer.
► Sélectionnez dans Modifier les propriétés de sur Y-Axe1(Bâtons) :
-De la même manière de précédent vous faites :
Etiquette de l’axe → (écrire) Effectif
Minimum →0 (Personnalisé)
Maximum → Automatique
Incrément principal → Automatique
La suit
Origine →0 (Personnalisé)
Type d’échelle → Linéaire
-Cliquez sur Appliquer.
► Faites glisser Distances (en milliers de km) de la liste Variables dans la zone de déplacement de
l'axe des x. Vous allez remarquer que les hauteurs de diagramme se changent.
► Vous pouvez également ajouter des titres au diagramme en suivant :
-Cliquez sur l'onglet Titres/Notes de bas de page et sélectionnez Titre1. Le titre apparaît sur le
canevas avec l'étiquette T1.
-Dans la fenêtre Propriété des éléments, sélectionnez Titre 1 dans Modifier les propriétés de liste.
-Dans la zone de texte Contenu, saisissez Effectifs des autocars selon la distance parcourue (pour
cet exemple). Il s'agit du texte que le titre affichera.
-Cliquez sur Appliquer pour enregistrer le texte. Bien que le texte ne soit pas affiché dans le
Générateur de diagrammes, il apparaît lorsque vous générez le diagramme.
► Cliquez sur ok pour créer le diagramme en bâtons.
Le diagramme en bâton s’affiche dans le Viewer.
La représentation graphique:
2 variable quantitative continue :
•
Une variable quantitative est dite continue dans un intervalle lorsqu’elle
peut prendre n’importe quelle valeur de cet intervalle.
Exemple :
•
Lors d’un contrôle de mathématique, les 400 étudiants ayant participé ont
eu les résultats suivants :
Notes
Nombres d’étudiants(Effectifs)
[0-4[
40
[4-8[
160
[8-12[
100
[12-16[
60
[16-20]
40
Remarque
*) Le logiciel SPSS analyse seulement les variables de type numérique,
mais dans ce type il est indispensable d’écrire des lettres, des
symboles ([, (…) dans l’Editeur de donnée pour saisir les données
d’une variable qualitative par exemple .Donc pour résoudre ce
problème vous contenterez à la notion des étiquettes de valeurs.
*) Les étiquettes de valeur correspondent à une façon d'associer aux
valeurs de variable des étiquettes de chaîne. L’importance de ces
étiquettes de valeurs c’est de rendent le type de n’importe quelle
variable (chaine, virgule, point…) numérique.
Pour obtenir les résultats de cet exemple sous
SPSS :
► A partir de l’Editeur de données cliquez sur Affichage des variables.
- Saisissez le nom de la variable Notes.
-Dans la ligne Notes cliquez sur la cellule de colonne Valeurs puis sur le bouton à droite de la
cellule pour ouvrir la boîte de dialogue Etiquettes de valeur.
- Le champ Valeur correspond à la valeur numérique réelle.
- Le champ Etiquette de valeur correspond à l'étiquette de chaîne appliquée à la valeur numérique
indiquée.
-Saisissez 2 dans le champ valeur et [0,4[dans le champ Etiquette de valeur.
- Cliquez sur Ajouter pour ajouter l'étiquette à la liste.
- Chaque fois vous prenez les centres de l’intervalle pour le champ valeur et l’intervalle pour le champ
Etiquette de valeur puis cliquez sur Ajouter.
- Cliquez sur OK pour enregistrer vos modifications et revenir dans l'éditeur de données.
► Dans l’Editeur de donnée au lieu de saisir les intervalles vous saisissez à leurs places ses centres(les
camps des valeurs).
-Pour faire afficher ces Etiquettes de valeurs sélectionnez :
Affichage à partir des menus puis cliquez sur Etiquette de valeur.
-Les étiquettes figurent à présent dans les données de la variable.
Les résultats donnés sous SPSS brutes cidessous :
• Tableau d’effectif :
[0,4[
Effectifs
40
Pourcentage
10,0
Pourcentage
cumulé
10,0
[4,8[
160
40,0
50,0
[8,12[
100
25,0
75,0
[12,16[
60
15,0
90,0
[16,20]
40
10,0
100,0
Total
400
100,0
Notes
Les étapes suivies pour afficher la représentation de
cet exemple sous SPSS :
Ouvrez à nouveau la boîte de dialogue Générateur de diagramme.
►Cliquez sur l’onglet galerie s’il n’est pas sélectionné puis sur Histogramme.
► Faites glisser l’icône de Diagramme : simple sur le « canevas ».
► Vous allez créer un diagramme qui affiche les rectangles des intervalles en fonction de leur effectif, donc il
y aura une variable qualitative sur l'axe x pour représenter les intervalles. En réalité la variable Notes est
numérique et donc pour créer le diagramme correctement, vous devez utiliser une variable qualitative.
► Cliquez avec le bouton droit de la souris sur Note dans la liste Variables et choisissez Ordinal. Notez que
les intervalles s’affichent au dessous de la liste de variable ( Elles sont les étiquettes de valeurs saisies
dans l’affichage des variables).
► Faites glisser la variable Note dans la zone de déplacement de l'axe des x.
► La zone de déplacement de l'axe des y prend par défaut la statistique Effectif.
► Si vous souhaitez utiliser une autre statistique (comme pourcentage ou moyenne), vous pouvez facilement
en changer (voir les pages 9 et 10).
► Cliquez sur l’onglet Titre/Notes de bas de page et sélectionnez Notes de bas page 1
►Dans la fenêtre Propriété des éléments, sélectionnez Notes de bas page 1 dans Modifier les propriété de
puis saisissez Histogramme des notes obtenues par les 400 étudiants ayant participé au contrôle Dans la
zone de texte Contenu.
► Cliquez sur Appliquer puis sur fermer.
► Cliquez sur ok.
La suite
Par analogie des tableaux vous pouvez également modifier un diagramme dans le Viewer
en suivant:
-Cliquez deux fois sur le diagramme (histogramme dans cet exemple) pour l’ouvrir
dans l’Editeur de diagramme.
-Sélectionnez le titre et choisissez une couleur dans l’outil de couleur.
-Pour modifier un élément de diagramme, sélectionnez-le.
- Les rectangles contenant les bâtons signifient qu'ils sont sélectionnés.
-Sélectionnez le diagramme et à partir des menus dans l’éditeur de diagramme
sélectionnez :
Elément → Afficher les étiquettes de données pour faire apparaître les effectifs sur les
rectangles.
-Sélectionnez un rectangle et dans l'outil Couleur du texte vous choisissez une couleur.
L’histogramme correspondant à cette série est de forme :
L’histogramme correspondant à cette série est de forme :
1-2 Variables qualitatives :
Une variable statistique est dite qualitative lorsqu’elle n’est ni mesurable ni repérable.
On utilise ici des caractéristiques appelées des "modalités" pour désigner ce
genre de variable. Dans ce cas on ne peut pas calculer les indices statistiques
numériques ; on se contentera ici de tableaux et de graphiques, comme illustré
dans l’exemple suivant :
Exemple :
Les réponses à la question « quelle est votre ville préférée lors de votre dernier séjour au
Maroc » que l’on ait posez à 40 touristes de nationalités différentes sont comme suit :
M ;M ;Me ;F ;F ;O ;A ;A ;C ;F ;Me ;M ;M ;A ;A ;O ;A ;O ;M ;O ;O ;A ;A ;M ;O
;F ;Me ;O ;C ;O ;A ;A ;M ;A ;F ;M ;A ;A ;O et A .
Les villes citées sont : Agadir (A) ; Casablanca (C) ; Fès (F) ; Marrakech (M) ;
Meknès (Me) et Ouarzazate (O).Ces informations peuvent être présentées sur le tableau
suivant donnée par SPSS, où la lecture est beaucoup plus simple :
► saisissez les données de cet exemple à l’aide des étapes précédentes avec les étiquettes de
valeurs.
Tableau d’effectif :
A
Effectifs
10
Pourcentage
27,0
Pourcentage
cumulé
27,0
C
2
5,4
32,4
F
5
13,5
45,9
M
8
21,6
67,6
O
9
24,3
91,9
Me
3
8,1
100,0
Total
37
100,0
Villes
Pour afficher le tableau ci-dessus, ouvrez la boite de dialogue Effectifs
puis cliquez sur Afficher les tableaux des Effectif puis sur ok.
► Les données relatives à cette variable qualitative peuvent être
représentez sous forme d’un diagramme en secteurs en utilisant la
boite de dialogue Générateur de diagramme.
► Vous pouvez aussi afficher la représentation graphique à partir de la
boite de dialogue Effectifs en cliquant sur Diagramme → Diagramme
en secteurs (type de diagramme) → Effectifs(valeur de diagramme) →
poursuive.
► Cliquez sur ok.
Le graphe s’afficher dans le Viewer. Vous pouvez faire apparaître les
fréquences des Villes de la même manière de l’exemple précédant.
Le graphe s’afficher dans le Viewer. Vous pouvez faire apparaître les
fréquences des Villes de la même manière de l’exemple précédant.
3- Statistique bidimensionnelle :
Dans ce paragraphe, on s’intéresse à l’étude simultanée de deux
variables, notée
X et Y, observées sur le même échantillon
observées sur n individus :
L’objectif est de mettre en évidence une éventuelle liaison entre les
deux variables, permettant dans certains cas, d’expliquer l’une à
partir de l’autre.
3-1 Deux variables quantitatives :
Les données de base sont constituées à partir de la série:
Où
et
On peut saisir les données sous formes d’un tableau de n lignes et 2
colonnes
a- Les indices statistiques :
La covariance : Elle est définit par :
Où
désignent les moyennes de X et Y.
le coefficient de corrélation :
Définition :
1.4 La Régression linéaire simple :
1.4.1 Introduction :
Lorsque deux variables quantitatives sont fortement corrélées, Il est naturel de
chercher à établir, dans un but explicatif et prévisionnel, une relation (qu’on
suppose) linéaire reliant les deux variables de la forme
ou a et
b sont deux réels à déterminer à partir des données. Le critère utilisé pour
déterminer a et b est le critère des « moindres carré ».
Critère des « moindres carrés »
Il consiste à trouver a et b minimisant la quantité suivante :
On notera que
représente, sur le graphique du nuage de points, la
distance verticale du point figurant sur la droite et le point
solution
La minimisation de S en a et b fournit la solution unique suivante :
Propriétés :
-) la droite d’équation Y= X +b est appelé droite de régression de Y sur X,
elle passe par le centre de gravité du nuage
.
-) Les valeurs
sont appelées valeurs estimées. Elles ont la même
valeur moyenne que Y.
-) les valeurs
sont appelés résidus, ils sont de moyenne nulle, et de
variance égale à
.
•
-) La variable X et la variable E des résidus sont non corrélées:
Qualité de la régression :
Comment apprécier la qualité de la régression de Y sur X ?la relation
obtenue. Permet elle de bien expliquer Y par X ?de bien prévoir Y à
partir de X ?
Il existe un indice, appelé coefficient de détermination permettant de juger
de la qualité de la régression c’est Plus sa valeur (positive) est proche
de 1, plus la qualité de la régression est bonne, et donc X explique bien
Y.
Exemple
Lors d’un examen, 12 candidats ont obtenus les notes suivantes (sur
20) à deux matières : mathématique et physique.
Candi 1
dat
4
2
3
4
5
6
7
8
9
10
11
12
7,75
8
10,5
12
12
12,75
13
14
14,75
15,5
16,5
6
7,75
10
11
12
13
13,5
14
14,75
15,5
16
Maths
Physiq 4,5
ue
Les étapes suivies pour obtenir les résultats sous SPSS :
Pour la covariance et la corrélation :
► A partir des menus dans l’éditeur de données sélectionnez :
Analyse → Echelle → Analyse de fiabilité.
► Sélectionnez les deux variables et déplacez-les dans la zone
Eléments.
► Cliquez sur Statistiques et choisissez Covariances et Corrélations
dans le groupe Récapitulatifs puis cliquez sur Poursuivre.
► Cliquez sur ok.
Les résultats sont :
Statistiques récapitulatives d'élément
Covariances entre éléments
Moyenne
13,830
Corrélations entre éléments
0,988
Pour la droite de régression
► A partir des menus dans l’éditeur de données sélectionnez :
Analyse → Régression → Linéaire.
► Déplacez-la variable Physique dans la case dépendant et la variable maths
dans la case variables indépendantes.
► Cliquez sur ok.
► Les tableaux vont afficher dans le Viewer.
► Modifiez vos résultats (masquer les données et les tableaux indésirables) à partir
de la boite de dialogue Barre d’outils.
Les données brutes ci-dessous :
-La droite de régression de la matière Physique sur Maths est:
Y= 0,996 X- 0,228
-Vous allez remarquez que le coefficient de corrélation de deux matières Maths
et Physique est retrouvé .il est notée dans le Viewer par et on a:
•
= = 0,988.
Le
c’est la corrélation au carrée avec
= = 0,976
Pour illustrer la notion de base de la création de
diagramme sous SPSS de cette exemple vous suivez :
A partir des menus dans l’éditeur des données sélectionnez :
► Graphe → Générateur de diagramme.
► Sélectionnez Galerie puis cliquez sur Dispersion/points
► Faites glisser l'icône du Diagramme de dispersion simple sur
le « canevas » puis la variable Maths dans la zone de l’axe des
x et Physique dans celle de l’axe des y.
► Cliquez sur ok.
La représentation graphique de nuage des points se présente
comme suit :
Pour crier la droite de régression de deux variables
dans le nuage des points suivez les étapes suivantes :
- Cliquez deux fois sur le nuage ci-dessus dans l’éditeur de résultats (le Viewer).
- A partir des menus dans l’éditeur du diagramme sélectionnez :
- Eléments → Ajouter une courbe d’ajustement au total.
- Cliquez en dehors de diagramme.
La représentation précédente se présente ainsi comme suit: :
La représentation précédente se présente ainsi
comme suit:
Une variable quantitative et une variable qualitative :
EXEMPLE
• Etudier la relation entre la variable
quantitative « âge» et variable qualitative
« situation familiale» dans une population de
30 personnes (masculins).
les données brutes ci-dessous
Age
Situation familiale
22
37
Célibataire
Célibataire
19
Célibataire
50
Célibataire
38
Célibataire
24
Célibataire
17
Célibataire
28
Célibataire
29
Célibataire
31
Célibataire
23
Célibataire
24
Célibataire
26
Célibataire
18
Célibataire
La suite du tableaux
30
Célibataire
15
Célibataire
75
Marié
37
Marié
45
Marié
81
Marié
33
Marié
21
Marié
42
Marié
29
Marié
65
Marié
53
Marié
36
Marié
49
Marié
40
Marié
68
Marié
Remarque
Vous pouvez saisir les données de cet exemple dans l’éditeur de données
comme il est déjà signalé avec que vous ajoutent Pour la variable
quantitative les étiquettes de valeurs ; par exemple 1pour marié et 0
pour Célibataire.
Pour calculer le rapport de corrélation sélectionnez :
► A partir des menus Analyse → Corrélation→ Bivariée.
► Dans la boite de dialogue Corrélation bivariée sélectionnez les deux
variables et déplacez- les dans la liste variables.
► Cliquez sur Pearson dans le groupe Coefficients de corrélations puis
sur ok.
Le rapport de corrélation d’âge et de situation familiale est :
la notion de base de la création de diagramme sous
SPSS de cette exemple vous suivez :
► Ouvrez à nouveau la boite de dialogue Générateur de diagramme.
► Sélectionnez dans l’onglet Galerie Boite à moustaches et faites
glisser l’icône du Boite à Moustaches simple sur le canevas.
► Cliquez avec la touche droite de la sourie sur la variable Situation
familiale dans la liste des variables et sélectionnez Nominale pour
faire afficher les étiquettes des valeurs.
► Cliquez sur ok.
Le diagramme s’est affiché dans le Viewer ayant la forme suivante :
Le diagramme s’est affiché dans le Viewer ayant la forme suivante :
3 .1 Les profils lignes et colonnes :
On appel
profil-ligne, l’ensemble des fréquences
de la variable Y
conditionnelles à la modalité de X (c'est-à-dire au sien de sons
population de Ω associée à cette modalité). Il s’agit donc des qualités :
.
On définit de façon analogue
le profil-colonne:
3.1 Les indices de laissons le khi-deux et ses dérivés :
Définition du khi-deux :
En conséquence, pour mesurer la liaison sur une table de contingence, donc l’indice
appelé « khi-deux », défini par :
Le coefficient
est toujours positif ou nul et est d’autant plus grand que liaison est
forte Malheureusement :
-) il dépond aussi des dimensions r et c de la table étudiée, ainsi que de la taille n de
l’échantillon observé.
-) en particulier, il n’est pas majoré. C’est la raison pour laquelle on a défini d’autres
indices :
Exemple :
Dans une population d’étudiants, on observé deux variables
qualitatives : la « Classe d’âge» avec 4 modalités :< 18 ans", "18
ans", "19 ans" 19 ans" ; et la « Durée d’obtention du DEUG », les
données sont présentés dans le tableau suivant :
< 18 ans
18 ans
19 ans
> 19 ans
somme
2 ans
84
224
73
19
400
3 ans
35
137
75
27
274
4 ans
14
59
34
16
123
Somme
133
420
182
62
797
on peut trouver le tableau ci-dessus appelé "tableau de
contingence" à l’aide de SPSS en suivant les étapes suivantes :
► A partir des menus, sélectionnez :
Analyse → Statistiques descriptives → Tableaux croisés.
► Sélectionnez la Durée d’obtention du DEUG comme variable de
ligne.
► Sélectionnez la Classe d’âge comme variable de colonne.
► Cliquez sur ok pour exécuter la procédure.
Les cellules du tableau indiquent l'effectif ou le nombre d'observations
pour chaque combinaison jointe de valeurs, par exemple 224 ont
eut le DEUG en 2ans ayant 18 ans.
Tableau croisé Durée d'obtention de DEUG * Classe d'âge
Classe d'âge
Durée
2 ans
d'obtention de
DEUG
3 ans
4 ans
Total
<18ans
84
18 ans
224
19 ans
73
> 19 ans
19
Total
400
35
137
75
27
274
14
59
34
16
123
133
420
182
62
797
les étapes suivies pour obtenir les résultas sous SPSS
Il est souvent difficile d'analyser un tableau croisé en regardant uniquement
les effectifs de chaque cellule. Pour résoudre ce problème vous vous
contenterez aux notions des profils lignes et colonnes.
► Ouvrez à nouveau la boîte de dialogue Tableaux croisés. (Les deux
variables doivent toujours être sélectionnées.)
► Cliquez sur Cellules.
►Pour afficher les profils lignes :
- Cliquez sur Lignes dans le groupe Pourcentages.
- Cliquez sur Poursuivre, puis sur Ok dans la boîte de dialogue principale
pour exécuter la procédure.
Le tableau est donnée par :
Tableau croisé Durée d'obtention de DEUG*classe d'âge avec les profils lignes
Classe d'âge
Durée
d'obtention
de DEUG
2 ans
3 ans
4 ans
Total
< 18ans
84
18 ans
224
19 ans
73
> 19 ans
19
Total
400
21,0%
56,0%
18,3%
4,8%
100,0%
35
137
75
27
274
12,8%
50,0%
27,4%
9,9%
100,0%
14
59
34
16
123
11,4%
48,0%
27,6%
13,0%
100,0%
133
420
182
62
797
16,7%
52,7%
22,8%
7,8%
100,0%
Pour afficher les profils colonnes :
- Cliquez sur Colonne (Position) dans le groupe Pourcentages.
- Cliquez sur Poursuivre, puis sur Ok dans la boîte de dialogue principale pour exécuter la
procédure.
Le tableau est donnée par:
Tableau croisé Durée d'obtention de DEUG * Classe d'âge avec les profils colonnes
Classe d'âge
Durée
2 ans
d'obtention
de DEUG
3 ans
4 ans
Total
< 18ans
84
18 ans
224
19 ans
73
> 19 ans
19
Total
400
63,2%
53,3%
40,1%
30,6%
50,2%
35
137
75
27
274
26,3%
32,6%
41,2%
43,5%
34,4%
14
59
34
16
123
10,5%
14,0%
18,7%
25,8%
15,4%
133
420
182
62
797
100,0%
100,0%
100,0%
100,0%
100,0%
Pour trouver les indices de liaison dans ce cas vous suivez :
► Ouvrez à nouveau la boîte de dialogue Tableaux croisés (Les deux variables doivent
toujours être sélectionnées).
► Cliquez sur Statistiques.
► Cliquez sur Khi-deux et sur Phi et V de Cramer dans le groupe Nominales.
► Cliquez sur Poursuivre, puis sur Ok dans la boîte de dialogue principale pour exécuter la
procédure.
Les données brutes dans le tableau ci-dessous :
Indices de liaisons
Khi-deux de Pearson
V de Cramer
Valeur
28,731
0,134
Nombre d'observations valides
797
Pour faire afficher la représentation graphique de cet
exemple vous suivez :
► Ouvrez à nouveau la boite de dialogue Générateur de diagramme puis
sélectionnez Galerie.
► A partir de Galerie vous choisissez Histogramme puis Histogramme :
superposé et vous lui faites glisser sur le « canevas ».
► Cliquez dans la liste des variables sur la touche droite da la sourie et
sélectionnez Ordinales pour les deux variables.
► Faites glisser l’un des variable (par exemple durée d’obtention de DEUG)
dans la zone de l’axe des x et l’autre dans la zone empiler :couleur définie).
► L’axe des y va prendre automatiquement la statistique effectif, si n’est pas le
cas vous pouvez modifier vos données en ouvrant la fenêtre Propriétés des
éléments.
► Pour ajouter un titre vous procédez de la même manière des exemples
précédents.
► Cliquez sur ok.
Le diagramme va afficher dans le Viewer sous la forme suivante :
Le diagramme va afficher dans le Viewer sous la forme
suivante :
Remarque :
Vous pouvez faire la représentation graphique de cet exemple appelé
Diagramme en Barres juxtaposé en siuvant :
- Ouvrez à nouveau la boite de dialogue Tableaux croisés (Les deux
variables doivent toujours être sélectionnées.) et sélectionnez Afficher les
diagrammes en batons juxtaposés puis cliquez sur ok.
Toutes les modifications de diagrammes faites de la même
manière des exemples précédents dans l’éditeur de
diagrammes.
Comme il est déjà signalé il est difficile d’analyser un tableau
de contingence selon les effectifs et donc pour établir la
entre les deux variables on utilise les indices de liaison.
dans cet exemple = 28,731 n’est pas grand ainsi que
C=0,134<0,5 ; on peut dire que la liaison deux variables
est faible.
4 – Conclusion
•
Les statistiques jouent un rôle très un important dans la
vie humaine, puisqu’elles sont les seuls chemins possibles d’analyser
des populations dans les différentes domaines. Cependant il est
difficile d’utiliser les formules mathématiques (donnée dans les cours
de probabilités et statistiques) dans les cas où les effectifs sont très
grands (des millions).
•
Le logiciel SPSS est un moyen parmi d’autre qui sert à
résoudre ce problème et d’exécuter des analyses et des tests
statistiques, sans devoir connaître les formules par cœur. Ainsi il
permet d’organiser et de présenter les résultats obtenus dans des
tableaux et des graphiques tout à fait modernes.
Merci pour votre
attention